Invalid session error
LD4all » Helpdesk

#1: Invalid session error Author: Alot PostPosted: Wed 03 May, 2017
    ----
Hi, so I've actually been experiencing this for some time now. When I try to make a post on my regular Chrome browser, I get the following error message:



Sometimes this also logs me out right after, but not always. This is also the same error I get when trying to update my profile or send a PM.

This issue only started after I deleted browsing history through an app. Before that, I had never encountered this error before. Also, only chrome was affected, and only ld4all. Other sites work as normal. (on the other hand, maybe I just haven't been making posts on other sites, though I think I did test this before.) Also, if I use my backup browser Dolphin, I can post as normal.

Recently, I also figured out another work-around, that using the same Chrome browser, I can post normally if I use incognito mode. So it seems that the issue is related to something with my settings, although I hadn't changed anything afaik.

#2:  Author: Mew151 PostPosted: Wed 03 May, 2017
    ----
Perhaps when you're deleting browsing history, you are also deleting cookies as well? Cookies manage your login state so if they are deleted, you will lose your login status. Logging in with incognito mode enabled makes sense with this theory, as most browser manage their private mode cookies in their own isolated bubble, so the only way to clear cookies of incognito mode is just closing the window. However, I haven't exactly been able to reproduce the exact error you are getting from just deleting my cookies before a post, as I simply get logged out when I delete all my cookies with no "Invalid Session" error.

The error "Invalid Session" in question sounds like more than just missing cookies. Do you ever see a "PHPSESSID=" or maybe "sid=" in your URL? Your URL might be passing in a weird wrong session ID, but I'm not sure exactly how LD4all's server is configured. If one does appear, you should be able to just cut out that part of the URL and refresh to see if that fixes anything.

To fix, I'd first look into the app setting to see if you are deleting just browsing history or browsing history and cookies, and see if there's a way you can preserve LD4all's cookies from being deleted. Or check if you didn't block LD4all from storing cookies on your computer in the first place. I mean, everyone loves LD4all cookies, right?

#3:  Author: Alot PostPosted: Thu 04 May, 2017
    ----
Thanks for the reply Mew151.

To clarify, I only did the delete browsing history thing once, and never again. Also I can't seem to find that option on my app anymore. It was just a security checking thing that popped up as a suggestion/threat and I happened to click yes that time.

I checked the url, and it's just a normal
Quote:
http://www.ld4all.com/forum/posting.php
after I click submit.

Chrome settings also say cookies are allowed, and it says "All Sites" as the header on the settings page.

Also I do get logged out randomly sometimes, even on incognito mode (even if the "keep me signed in" box was checked). Usually when I come back to the page after leaving it open in the background. It's like the browser reloaded and didn't keep the previous session.

#4:  Author: Eilatan PostPosted: Thu 04 May, 2017
    ----
Alot wrote:
I checked the url, and it's just a normal
Quote:
http://www.ld4all.com/forum/posting.php
after I click submit.


I'm rather confused as to how you got this url. This url isn't valid, and leads no where.

For instance, if I click "Post Reply" to this topic, I get the url:
Code:
http://ld4all.com/forum/posting.php?mode=reply&t=5068 7


Since I am quoting your post, I get the url:
Code:
http://ld4all.com/forum/posting.php?mode=quote&p=7374 89


If I try to "Post a new topic" in the Helpdesk (as your first screenshot shows), I get the following url
Code:
http://ld4all.com/forum/posting.php?mode=newtopic&f=9


Are you getting the correct urls with the "mode=" details in them? Or are your urls ending with "posting.php" because if so, this seems to be a redirecting issue.

#5:  Author: Alot PostPosted: Thu 04 May, 2017
    ----
Yeah I get the same urls with the "mode=" details. The the one that ends in "posting.php" should be what you get if you click the Preview button, or submit button after editing a previously posted post?

I tried quoting your post, and this time got this longer url with the same invaild session error:
Code:
http://www.ld4all.com/forum/posting.php?sid=0826d39df 24ac6bf4417afc6309ca983


This one logged me out, and when I tried to reply again, I got redirected to the login page:
Code:
http://ld4all.com/forum/login.php?redirect=posting.ph p&mode=reply&t=50687

#6:  Author: Arial PostPosted: Sat 16 Sep, 2017
    ----
Hi!
I'm having the same issue. Also using chrome, on my phone (on laptop I don't encounter the issue. But my laptop broke down yesterday so now on my phone)
While writing this post the url was

http://ld4all.com/forum/posting.php?mode=reply&t=5068 7&sid=f223f531c70d0d17 fe81ad9fa8fbd648

Then after trying to post it and getting the error:
http://ld4all.com/forum/posting.php?sid=d102a53455ed3 606230019ba4b046752

So there's that Sid thing. And php.

I'll now try my luck in an incognito tab, because the eye occurs for me all the time otherwise. The it'll now is

http://www.ld4all.com/forum/posting.php?mode=reply&t= 50687

Let's see. Edit: yes in incognito it works. So at least I can keep using the forum like this smile

#7:  Author: Siiw PostPosted: Sat 16 Sep, 2017
    ----
I sometimes get this error if it takes a long time to write the post. This is why I always save the text if it is for example a long dream. I don't know what the time limit is, but it is short enough to make the error appear if I tab out or write a lot.



LD4all » Helpdesk


Page 1 of 1
printed from the LD4all.com lucid dreaming forum. Content copyrighted by the author.
Lucid dreamers unite! visit LD4all.com